Hi, I ran into the following error trying to build rescue/rescue as part of buildworld on 10.2-RELEASE-p7 / i386. Has anyone seen this before? Thanks, -NGie % git log --show-notes --grep svn -n 1 commit 69774947bfffd5e16d26b60a82d880aa659abbf2 Author: imp <imp_at_FreeBSD.org> Date: Sat Dec 19 19:20:48 2015 +0000 Move some MIPS specific flags to be more congruent with other architectures. Notes: svn path=/head/; revision=292474 % env NO_CLEAN=1 make buildworld -j2 ... --- rescue --- cc -static -o rescue rescue.o cat.lo chflags.lo chio.lo chmod.lo cp.lo date.lo dd.lo df.lo echo.lo ed.lo expr.lo getfacl.lo hostname.lo kenv.lo kill.lo ln.lo ls.lo mkdir.lo mv.lo pkill.lo ps.lo pwd.lo realpath.lo rm.lo rmdir.lo setfacl.lo sh.lo sleep.lo stty.lo sync.lo test.lo badsect.lo camcontrol.lo ccdconfig.lo clri.lo devfs.lo dmesg.lo dump.lo dumpfs.lo dumpon.lo fsck.lo fsck_ffs.lo fsck_msdosfs.lo fsdb.lo fsirand.lo gbde.lo geom.lo ifconfig.lo init.lo kldconfig.lo kldload.lo kldstat.lo kldunload.lo ldconfig.lo md5.lo mdconfig.lo mdmfs.lo mknod.lo mount.lo mount_cd9660.lo mount_msdosfs.lo mount_nfs.lo mount_nullfs.lo mount_udf.lo mount_unionfs.lo newfs.lo newfs_msdos.lo nos-tun.lo ping.lo reboot.lo restore.lo rcorder.lo route.lo routed.lo rtquery.lo rtsol.lo savecore.lo spppcontrol.lo swapon.lo sysctl.lo tunefs.lo umount.lo ping6.lo zfs.lo zpool.lo bsdlabel.lo sconfig.lo fdisk.lo dhclient.lo head.lo mt.lo nc.lo sed.lo tail.lo tee.lo gzip.lo bzip2.lo less.lo xz.lo tar.lo id.lo zdb.lo chroot.lo chown.lo /usr/obj/usr/src/git/rescue/rescue/../librescue/exec.o /usr/obj/usr/src/git/rescue/rescue/../librescue/getusershell.o /usr/obj/usr/src/git/rescue/rescue/../librescue/login_class.o /usr/obj/usr/src/git/rescue/rescue/../librescue/popen.o /usr/obj/usr/src/git/rescue/rescue/../librescue/rcmdsh.o /usr/obj/usr/src/git/rescue/rescue/../librescue/sysctl.o /usr/obj/usr/src/git/rescue/rescue/../librescue/system.o -lcrypt -ledit -ljail -lkvm -lelf -ll -ltermcapw -lutil -lxo -l80211 -lalias -lcam -lncursesw -ldevstat -lipsec -llzma -lavl -lzpool -lzfs_core -lzfs -lnvpair -lpthread -luutil -lumem -lgeom -lbsdxml -lkiconv -lmt -lsbuf -lufs -lz -lbz2 -larchive -lcrypto -lmd -lm nc.lo: In function `_$$hide$$ nc.lo main': (.text+0x750): warning: warning: mktemp() possibly used unsafely; consider using mkstemp() --- all_subdir_sbin --- --- ea.o --- cc -O2 -pipe -O2 -pipe -I/usr/src/git/sbin/fsck_ffs -I/usr/src/git/sbin/fsck_ffs/../mount -g -MD -MP -MF.depend.ea.o -MTea.o -std=gnu99 -fstack-protector-strong -Wsystem-headers -Werror -Wall -Wno-format-y2k -Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int -Wno-unused-const-variable -Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality -Wno-unused-function -Wno-enum-conversion -Wno-unused-local-typedef -Wno-switch -Wno-switch-enum -Wno-knr-promoted-parameter -Qunused-arguments -c /usr/src/git/sbin/fsck_ffs/ea.c -o ea.o --- fsutil.o --- cc -O2 -pipe -O2 -pipe -I/usr/src/git/sbin/fsck_ffs -I/usr/src/git/sbin/fsck_ffs/../mount -g -MD -MP -MF.depend.fsutil.o -MTfsutil.o -std=gnu99 -fstack-protector-strong -Wsystem-headers -Werror -Wall -Wno-format-y2k -Wno-uninitialized -Wno-pointer-sign -Wno-empty-body -Wno-string-plus-int -Wno-unused-const-variable -Wno-tautological-compare -Wno-unused-value -Wno-parentheses-equality -Wno-unused-function -Wno-enum-conversion -Wno-unused-local-typedef -Wno-switch -Wno-switch-enum -Wno-knr-promoted-parameter -Qunused-arguments -c /usr/src/git/sbin/fsck_ffs/fsutil.c -o fsutil.o --- all_subdir_rescue --- /usr/obj/usr/src/git/tmp/usr/lib/libkvm.a(kvm.o): In function `_kvm_open': /usr/src/git/lib/libkvm/kvm.c:444: undefined reference to `__start_set_kvm_arch' /usr/src/git/lib/libkvm/kvm.c:444: undefined reference to `__stop_set_kvm_arch' /usr/src/git/lib/libkvm/kvm.c:444: undefined reference to `__stop_set_kvm_arch' cc: error: linker command failed with exit code 1 (use -v to see invocation) *** [rescue] Error code 1 bmake[5]: stopped in /usr/obj/usr/src/git/rescue/rescue 1 error bmake[5]: stopped in /usr/obj/usr/src/git/rescue/rescue *** [rescue] Error code 2 bmake[4]: stopped in /usr/src/git/rescue/rescue 1 error bmake[4]: stopped in /usr/src/git/rescue/rescue *** [all] Error code 2 bmake[3]: stopped in /usr/src/git/rescue 1 error bmake[3]: stopped in /usr/src/git/rescue *** [all_subdir_rescue] Error code 2 … $ cc --version FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512 Target: i386-unknown-freebsd10.2 Thread model: posix $ strings /usr/obj/usr/src/git/tmp/usr/lib/libkvm.a | egrep -n '__(stop|start)_set_kvm_arch' 97:__start_set_kvm_arch 98:__stop_set_kvm_arch 140:__start_set_kvm_arch 141:__stop_set_kvm_arch 182:__start_set_kvm_arch 183:__stop_set_kvm_arch 233:__start_set_kvm_arch 234:__stop_set_kvm_arch 296:__start_set_kvm_arch 297:__stop_set_kvm_arch 395:__start_set_kvm_arch 396:__stop_set_kvm_arch 472:__start_set_kvm_arch 473:__stop_set_kvm_arch 526:__start_set_kvm_arch 527:__stop_set_kvm_arch 589:__start_set_kvm_arch 590:__stop_set_kvm_arch 651:__start_set_kvm_arch 652:__stop_set_kvm_arch 711:__start_set_kvm_arch 712:__stop_set_kvm_arch 3510:__start_set_kvm_arch 3585:__stop_set_kvm_arch 3970:__start_set_kvm_arch 3971:__stop_set_kvm_arch $Received on Sat Dec 19 2015 - 23:03:58 UTC
This archive was generated by hypermail 2.4.0 : Wed May 19 2021 - 11:41:01 UTC