Re: CURRENT crashes at early boot on Lenovo T540p: rtsx to blame - 13.0-RELEASE crashes same way!

From: Henri Hennebert <hlh_at_restart.be>
Date: Wed, 12 May 2021 20:49:14 +0200
On 5/12/21 8:01 PM, Marc Veldman wrote:
> 
> 
>> On 12 May 2021, at 18:06, Henri Hennebert <hlh_at_restart.be> wrote:
>>
>> On 5/12/21 5:04 PM, Marc Veldman wrote:
>>> Unfortunately I can only say me too, but on a different Lenovo laptop.
>>> Ive put my diagnostics in this thread, with the SVN revision in which it seems to have broken.
>>> https://docs.freebsd.org/cgi/getmsg.cgi?fetch=327822+0+archive/2020/freebsd-current/20201227.freebsd-current
>>
>> I your first message on the thread I see
>>
>> "mmc0: detached"
>>
>> do you have the previous lines of the dmesg?
>>
> 
> This is what I can see on the display:
> (Copied by hand, so there might be some typos)
> 
> pcib2: <ACPI PCI-PCI bridge> at device 28.2 on pci0
> pci2: <ACPI PCI bus> on pcib2
> pci2: <network> at device 0.0 (no driver attached)
> pcib3: <ACPI PCI-PCI bridge> at device 29.0 on pci0
> pci3: <ACPI PCI bus> on pcib3
> vgapci1: <VGA-compatible display> port 0xd000-0xd07f mem 0xf3000000-0xf3ffffff,0xe0000000-0xefffffff,0xf0000000-0xf1ffffff at device 0.0 on pci3
> isab0: <PCI-ISA bridge> at device 31.0 on pci0
> isa0: <ISA bus> on isab0
> pci0: <memory> at device 31.2 (no driver attached)
> hdac0: <Intel Sunrise Point-LP HDA Controller> mem 0xf4240000-0xf4243fff,0xf4230000-0xf423ffff at device 31.3 on pci0
> em0: <Intel(R) I219-V SPT> mem 0xf4200000-0xf421ffff at device 31.6 on pci0
> em0: Using 1024 TX descriptors and 1024 RX descriptors
> em0: Using an MSI interrupt
> em0: Ethernet address: 54:ee:75:cb:0d:e3
> em0: netmap queues/slots: TX 1/1024, RX 1/1024
> acpi_tz0: <Thermal Zone> on acpi0
> atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
> atkbd0: <AT Keyboard> irq 1 on atkbdc0
> kbd0 at atkbd0
> atkbd0: [GIANT-LOCKED]
> psm0: <PS/2 Mouse> irq 12 on atkbdc0
> psm0: [GIANT-LOCKED]
> WARNING: Device "psm" is Giant locked and may be deleted before FreeBSD 14.0.
> psm0: model Synaptics Touchpad, device ID 0
> battery0: <ACPI Control Method Battery> on acpi0
> battery1: <ACPI Control Method Battery> on acpi0
> acpi_acad0: <AC Adapter> on acpi0
> orm0: <ISA Option ROM> at iomem 0xc0000-0xcffff pnpid ORM0000 on isa0
> hwpstate_intel0: <Intel Speed Shift> on cpu0
> hwpstate_intel1: <Intel Speed Shift> on cpu1
> hwpstate_intel2: <Intel Speed Shift> on cpu2
> hwpstate_intel3: <Intel Speed Shift> on cpu3
> Timecounters tick every 1.000 msec
> ZFS filesystem version: 5
> ZFS storage pool version: features support (5000)

Do you see an rtsx message before this mmc0 ?

> mmc0: detached
> ugen0.1: <0x8086 XHCI root HUB> at usbus0
> 
> Fatal trap 9: general protection fault while in kernel mode
> cupid = 3; apic id = 03
> .
> .
> 
> Im not sure if this is an interesting data point or not,
> but a warm boot without the card inserted succeeds after
> a cold boot with the card inserted.

This remind me of a case of rebooting FreeBSD after a window session.
I will check in my mail archive...

Thank you for your time

> 
> Best regards,
> 
> Marc Veldman
> 
> 
> 
Received on Wed May 12 2021 - 16:49:23 UTC

This archive was generated by hypermail 2.4.0 : Wed May 19 2021 - 11:41:28 UTC